Announcement - 2018-9-17,17:52:32


#1

Please hold off on updating your wallets. The previous release announced a few hours ago(removed) was an incorrect build missing some updates. The correct release build will follow.

If you have already upgraded to this previous release that’s okay, but will need to update again with the new release.