Announcement - 2018-9-8


#1

REMINDER
@everyone The 3.10.2 wallet update is mandatory for Service Nodes and anybody using Block DX due to the change in fees. Service Nodes that don’t update will not receive any fees. Block DX users that don’t update will not be able to view orders.

Wallet:

If you haven’t updated yet, please do so as soon as possible!